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ABSTRACT
: 

Tampere University

 

The abstract is a concise 1-page description of the work: what was the problem, what was done, and what are the results. Do not include charts or tables in the abstract.
Put the abstract in the primary language of your thesis first and then the translation (when that is needed).
This document template has two text styles for abstract. BibInfo is for bibliographical information above whereas the rest uses the style Abstract, which has line spacing of 1.0. The style Heading (no number) is used in the frontmatter before actual text and it makes the necessary preceding page break. Similar style is used in the bibliography with slightly different name in order to include it in the table of contents. The title page must end with Section Break to get pages numbered correctly. Moreover, the header on this page turns off the setting Link to Previous and formats the page numbers to Start at 1 (instead of Continue).



Keywords: After Abstract-text

The originality of this thesis has been checked using the Turnitin Originality Check service.



TIIVISTELMÄ
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Tampereen yliopisto

 

Abstract in Finnish. Foreign students do not need this page.
Suomenkieliseen diplomityöhön kirjoitetaan tiivistelmä sekä suomeksi että englanniksi. Kandidaatintyön tiivistelmä kirjoitetaan ainoastaan kerran, samalla kielellä kuin työ. Kuitenkin myös suomenkielisillä kandidaatintöillä pitää olla englanninkielinen otsikko arkistointia varten.



Avainsanat: Tiivistelmä-tekstin jälkeen

Tämän julkaisun alkuperäisyys on tarkastettu Turnitin Originality Check -ohjelmalla.
Preface
This document template conforms to the Guide to Writing a Thesis in Technical Fields at Tampere University (2019).
Acknowledgements to those who contributed to the thesis are generally presented in the preface. It is not appropriate to criticize anyone in the preface, even though the preface will not affect your grade. The preface must fit on one page. Add the date, after which you have not made any revisions to the text, at the end of the preface.
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[bookmark: _Toc535516164]Introduction
This document template conforms to the Tampere University Guide to.writing a thesis in technical fields [5]. A thesis or a report typically include the following chapters:
Title page
Abstract
Preface
Contents
List of abbreviations and symbols
1. Introduction
2. Theoretical background
3. Research methodology and materials
4. Results and analysis (possibly split into separate chapters)
5. Conclusions
References
Appendices (if applicable)
Each of these chapters starts from a new page in a thesis. The titles of chapters from 1 to 5 are provided as examples only. You should use more descriptive ones.
The title page of your thesis features the University’s logo your name, the thesis title and type (Licenciate Thesis, Master’s Thesis, Bachelor’s Thesis or Course work). The time when the thesis has been submitted for examination (month and year) is also stated in the right hand lower corner. The table of contents lists all the numbered headings after it, but not always the preceding headings. MS Word has an automated feature to do this by selecting References > Table of Contents.
Introduction outlines the purpose and objectives of the presented research. The background information, utilized methods and source material are presented next at a level that is necessary to understand the rest of the text. Then comes the discussion regarding the achieved results, their significance, error sources, deviations from the expected results, and the reliability of your research. Conclusions is the most important chapter. It does repeat the details already presented, but summarizes and them and analyzes their consequences. List of references enables your reader to find the cited sources.
This document is structured as follows. Chapter 2 discusses briefly the basics of writing and presentation style regarding the text, figures, tables and mathematical notations. Chapters 3 and 4 summarize the referencing basics and the whole document. Some remarks on using styles in MS Word are included as an appendix.
[bookmark: _Toc535516165][bookmark: _Toc363738141][bookmark: _Toc535531169][bookmark: _Hlk19086994]Writing style
Effective written communication requires both sound content and clear style. Keep the layout of your thesis neat and pay attention to your writing style 
[bookmark: _Toc535516166]Text
A thesis is written with a single-column layout. The font type of the body text is Arial and the font size is 11 pt. The spacing is 1,5. and the text is fully justified and hyphenated. The abstract is written with Arial 10 pt with spacing of 1. In the abstracts paragraphs are intended
Arial 18 pt font is used for the headings in this guide, and there is a 42 pt space above and below. The font size of subheadings is 14. There is an18 pt space above subheadings and 12 pt space below them.
Brief basics of writing style are:
Always think of your reader when you are writing and proceed logically from general to specific.
Highlight your key points, for example, by discussing them in separate chapters or presenting them in a table or figure. Use italics or boldface for emphasis, but don’t overdo it. 
Avoid long sentences and complicated statements. A full stop is the best way to
end a sentence. 
Use active verbs to make a dynamic impression but avoid the first person pronoun “I”, except in your preface. 
Avoid jargon and wordiness. Use established terminology and neutral language.
The minimum length of chapters and subchapters is two paragraphs, and you need to consider the balance of chapters. Paragraphs must always consist of more than one sentence. 
Do not use more than three levels of headings, such as 4.4.2. 
Do not use too many abbreviations. Use capital and small letter consistently. 
The text is formated as style Body text. Its language is here set to English but that is easy to change to e.g. Finnish. There are 4 styles for headings: Heading1, 2 ja 3 for mainmatter and Heading (no number) for frontmatter and bibliography. Three kinds of lists are available List (numbered), List (bullets), and List (no bullets or numbers). If and when your text formatting breaks, select it and click Clear All from style menu. Then apply the desired style from the menu. Some more remarks are in Appendix 1.
[bookmark: _Toc381026012][bookmark: _Toc381026470][bookmark: _Toc381539801][bookmark: _Toc381541019][bookmark: _Toc381541091][bookmark: _Toc381541164][bookmark: _Toc381541238][bookmark: _Toc381541313][bookmark: _Toc381026013][bookmark: _Toc381026471][bookmark: _Toc381539802][bookmark: _Toc381541020][bookmark: _Toc381541092][bookmark: _Toc381541165][bookmark: _Toc381541239][bookmark: _Toc381541314][bookmark: _Toc381026014][bookmark: _Toc381026472][bookmark: _Toc381539803][bookmark: _Toc381541021][bookmark: _Toc381541093][bookmark: _Toc381541166][bookmark: _Toc381541240][bookmark: _Toc381541315][bookmark: _Toc381026015][bookmark: _Toc381026473][bookmark: _Toc381539804][bookmark: _Toc381541022][bookmark: _Toc381541094][bookmark: _Toc381541167][bookmark: _Toc381541241][bookmark: _Toc381541316][bookmark: _Toc381026016][bookmark: _Toc381026474][bookmark: _Toc381539805][bookmark: _Toc381541023][bookmark: _Toc381541095][bookmark: _Toc381541168][bookmark: _Toc381541242][bookmark: _Toc381541317][bookmark: _Toc381026017][bookmark: _Toc381026475][bookmark: _Toc381539806][bookmark: _Toc381541024][bookmark: _Toc381541096][bookmark: _Toc381541169][bookmark: _Toc381541243][bookmark: _Toc381541318][bookmark: _Toc535516167][bookmark: _Toc118865070][bookmark: _Toc119224917][bookmark: _Toc363738142][bookmark: _Toc535531170]Figures
You must refer to all the figures in the body text. The reference should preferably appear on the same page as the actual figure or before it. Figures and tables must be numbered consistently thesis and primarily placed at the top of the page, but you are free to decide where they fit best. Never start a chapter with a figure, table or list.

[image: ][image: kuva1]
[bookmark: _Toc535515835][bookmark: _Ref19525053][bookmark: _Ref19525118][bookmark: _Ref19525158][bookmark: _Ref19529675]Diagrams should be edited before publication. The diagram on the right is an edited version of the one on the left
Figures and the caption are either consistently centered (or aligned to the left). The caption is placed under the figure and always on the same page as the figure. All figures must be explained in the body text, so that readers know what they are supposed to notice. Figures generated by analysis software usually need further editing, see Figure 1 for example. The figures should be in the same language as other text (even if Figure 1 violates this recommendation). The recommended font size is the same as that of the body text, 11 pt. The figures must be readable, even if your thesis is printed in greyscale.
Figures can be inserted by clicking Insert > Picture or directly copy-pasting from another program In the later case, it is better to use Paste special > Picture (Enhanced metafile), because pasting as MS office graphic object causes often problems. Figure 1 is here actually inside a borderless table with 2 rows to get subfigures nicely aligned. Figures must be updated several times during writing. Select the figure with mouse and then with right mouse button Change picture, and then select the new figure file. This way all the figure size and other settings are kept. References are inserted by References > Cross-reference > Insert reference to: Paragraph number. The text style Figure Caption creates running numbering automatically. Another option is to select the figure and then with right mouse button Insert Caption. This also allows numbering format 2.1, where the first number denotes the chapter.
1. [bookmark: _Ref19529763]Example of evaporation conditions in a thin film structure.
	[bookmark: _Hlk19087259]Sub-stance
	Thickness (nm)
	Correction coefficient
	Pressure (mbar)
	Temperature ([image: ]C)
	Current (mA)
	Speed (nm/s)

	SiO2
	181.0
	1.10
	3.0∙10-5
	90.6
	20−23
	0.2

	TiO2
	122.1
	1.55
	15.0∙10-5
	91.1
	100−93
	0.1


[bookmark: _Toc535516168]Tables
Tables are convenient for presenting information in a concise way, especially numerical data.Tables have numbered captions, see Table 1 for example. The caption is placed on the same page but above the table, unlike the captions that accompany figures. You must refer to all the tables in the body text. In addition, you must discuss the content of any tables in the body text to ensure that readers understand their relevance.
Text style Table Caption has automatic numbering and also the settings Keep with Next and Keep lines together. Start with Insert > Table. It is good to open the table’s properties. Ensure that the setting Allow row to break across pages is not activated. Select Alignment:Center ja Text wrapping:Around. After that it is easy to place the table neatly at top of the page by clicking Positioning and selecting Vertical Position 0 cm Relative to Margin. Moreover, you may set Distance to surrounding text: Bottom 0.5 cm, so that there is a clean gap before text without any nasty line breaks. Upon referring to a table, select References > Cross-reference > Insert reference to: Paragraph number. There are four text styles Table header (left) and (right) as well as Table cell (text) and (number) differing in boldface and alignment.
Mark the titles of the columns and units clearly. You can use boldface to highlight the titles and use a double horizontal line to separate from the rest of the table. The order of the columns and rows must be carefully considered. Do not surround all the cells with a border, as it may make your table harder to read. Put a line on top and bottom of the table. You can add a horizontal line between every 4–5 rows, if the data is not grouped into categories. If the table is large, the rows should be numbered if you plan to refer to the rows in the body text.
The numbers are right aligned (optimally lined up at the decimal point) for easy comparison. You should preferably use SI units, established prefixes and rewrite large numbers so that the power of ten should be placed in the title of the column instead of each row, if possible. More suggestions can be found in [4].
[bookmark: _Toc118865071][bookmark: _Toc119224919][bookmark: _Toc121032630][bookmark: _Toc363738144][bookmark: _Toc535516169][bookmark: _Toc118865072][bookmark: _Toc119224926]Mathematical notations 
[bookmark: _Toc119224921][bookmark: _Toc121032632]Numbers are generally written using numerals for the sake of clarity, for example “6 stages” rather than “six stages”, which is nevertheless strongly preferred to “a couple of stages”. You should also use a thousand separators[footnoteRef:1], i.e. instead of 55700125 write 55 700 125. Never omit the leading zero in decimals. For example, it is correct to write “0.5” and wrong to write “.5”. A comma is used as a decimal separator in the Finnish language and a period in the English language.  [1:  In LaTeX, you can do this by replacing a space with the character ”~”. In Word, you can use the non-breaking space symbol.] 

Like numbers, it is advisable to abbreviate units of measurement. There is a space between the number and the unit, but you should keep them on the same line1. It is better to compile a table or graph than include a great deal of numerical values in the body text. Use precise language and put numbers on a scale (small, fast, expensive).
Use generally known and well defined concepts and standard conventions and symbols for representing them. New concepts should be defined when they appear in the text for the first time. Upper case and lower case letters mean different things in symbols and units of measurement. Do not use the same symbol to mean different things.
For mathematical symbols and equations, select either Insert > Symbol (or Equation). Newton’s Second Law can be presented in the following way: 
											      (1)
where m denotes the mass of an object, a means acceleration, and F means force. Please note that all the variables must be defined at the point of their first appearance. All sentences end with a punctuation mark, and the main elements of a sentence are separated by a comma in accordance with the rules of English grammar.  Mathematical formulas are numbered, if they are written on separate lines and referred to in the main body of the text. The number is usually put in parenthesis and right aligned, see equation (1) for example. Occasionally mathematical notations are preceded by an identifier, such as Definition 1 or Theorem 1 [3]. Simple formulas may be displayed within the body of the text without numbering.
Do not start a sentence with a mathematical symbol but add some word, such as the name or type of the symbol, in front of it. Variables, such as x and y, are generally presented in italics, whereas elementary functions, special functions and operators are not: 
	sin(2x+y), 	grad T, 	div B, 	lim (x2 – 1)/(x + 1).
At first, it is better to rely on the automated formatting of an equation editor. You may have to make compromises between logical clarity and readability.
Programs and algorithms
Codes and algorithms are written using monospaced font, such as Courier New, Consolas or their variations (for example LaTeX has so called teletype). If the length of the code or algorithm is less than 10 lines and you do not refer to it later on in the text, you can present it similarly to formulas.
If the code is longer but shorter than a page, you present like a figure (Program.1) titled “Program” or “Algorithm”. This template has text styles: Code, Code row number ja Code Caption. You should also mark reserved words in boldface. This example code is placed inside a table. 
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	void sort( charPair arr[], int size )
{

  // Sort a table so that each round looks up the smallest remaining
  // letter and moves it to correct location.
  for( int i = 0; i < size; ++i )
  {
    // Find the smallest, i.e. closest to letter ‘a’
    int idxSmallest = i;
    for( int j = i; j < size; ++j )
    {
      if( arr[ j ].replacable
          < arr[ idxSmallest ].replacable  )
      {
         idxSmallest = j;
      }
    }
    // Move the smallest item to its correct location
    charPair tmp       = arr[ i ];
    arr[ i ]           = arr[ idxSmallest ];
    arr[ idxSmallest ] = tmp;
  }
  return;
}

	Example of presenting programming code as a figure in a thesis.


You should add some comments to the code and indent it consistently. The actions performed by the code must be outlined in broad terms in the body text. Line numbers make it much easier to refer to the code in the text. LaTeX has a package listings [1] [2] which can handle code very conveniently, include real code files, add row numbers, and highlight the reserved words. 

[bookmark: _Toc393282515][bookmark: _Toc535516170][bookmark: _Toc535531173]REFERENCING STYLES 
Different referencing styles determine how you create 1) in-text citations and 2) the bibliography. Two common referencing styles are presented in this chapter: 
Numeric referencing (Vancouver system), such as [1],[2]…
Name-year system (Harvard system), such as (Weber 2001), (Kaunisto 2003)…
A numeric reference is inserted in square brackets [], whereas the last name of the author and the year of publication are given in round brackets (). 
Both styles are acceptable, but the conventions for referencing vary between disciplines. You must pick one and use is consistently throughout your thesis. 
[bookmark: _Toc535516171]In-text citations
In-text citations are placed within the body of the text as close to the actual citation as possible. The citation is generally placed within the sentence before the full stop.
Weber argues that … [1]. 
Cattaneo et al. introduce in their study [2] a new…
The result is … [1, p. 23]. One must also note… [1, s. 3336]

In accordance with the presented theory … (Weber 2001).
It must especially be noted… (Cattaneo et al.).
Weber (2001, p. 230) has stated…

Based on literature in the field [1,3,5]…
Based on literature in the field [1][3][5]…
The topic has been widely studied [6–18]…

…existing literature (Weber 2001; Kaunisto 2003; Cattaneo et al. 2004) has …

Select References > Cross-reference > Insert reference to: Paragraph number to create an in-text references to bibliography, figures, or tables. The numbering will evidently change upon editing. First select all text (CTRL+a or Select > Select All), then from right-mouse button menu select Update Field, and finally Update entire Table. When a reference is broken– e.g. the target was removed –the text includes ”Error! Reference source not found” in boldface. Check that your text does not have any of them. In MS Word, the cross-references may easily break otherwise as well, e.g. point to [12] instead of [13]. These are problems are harder to detect and correcting them requires zen-like patience, concentration, and lots of repetitions.
[bookmark: _Toc535516172][bookmark: _Toc363738160]Bibliography
The entries must include all the details listed in Table 2 below. 
 
Table 1. [bookmark: _Ref394669842]Necessary bibliographic information.
	#
	Numeric system
	#
	Name-year system

	1.
	authors,
	1.
	authors,

	
	
	2.
	(year in parentheses)

	2.
	title,
	3.
	title,

	3.
	publisher,
	4.
	publisher,

	4.
	year of publication,
	
	

	5.
	pages,
	5.
	pages,

	6.
	URL, if applicable
	6.
	URL, if applicable



Formatting examples of a journal article in bibliography are provided below, first in the numeric style and then the name-year style.
[100]	K. Keutzer, A.R. Newton, J.M. Rabaey, A. Sangiovanni-Vincentelli, System-level design: orthogonalization of concerns and platform-based design, IEEE Transactions on Computer-Aided Design of Integrated Circuits and Systems, vol.19, no.12, Dec 2000, pp.1523‒1543.

Keutzer, K., Newton, A.R., Rabaey, J.M. & Sangiovanni-Vincentelli A. (2000). System-level design: orthogonalization of concerns and platform-based design. IEEE Transactions on Computer-Aided Design of Integrated Circuits and Systems. Vol.19(12), s.1523‒1543.

Your references are listed at the end of your thesis in alphabetical order based on the first author’s last name. If the author is unknown, alphabetize the source using the cor-porate author or title. This template uses text style BibItem.
[bookmark: _Toc535516173]Conclusions
This template and the writing guidelines should help achieving a consistently formatted and clear documents. Similar template is also available for LaTeX.
Every writing and presentation must have a conclusion. This fact is here emphasized by having this short and rather artificial summary also in this template. A concise summary table is a good way for providing an overview of the most important points.
[bookmark: _Toc535516174][bookmark: _Toc535531177]REFERENCES 
[bookmark: _Ref19529957]C. Heinz, B. Moses, J. Hoffmann, Listings - Typeset source code listings using LaTeX, Comprehensive TeX Archive Network (CTAN), 2006. Available: http://www.ctan.org/pkg/listings
[bookmark: _Ref395517103]T. Oetiker, H. Partl, I. Hyna, E. Schlegl, The Not So Short Introduction to LATEX2ε – Or LATEX2ε in 157 minutes, Version 5.03, 2014, 171 p. Available: http://www.ctan.org/tex-archive/info/lshort/english/
[bookmark: _Ref19530672]K. Ruohonen, Matemaattisen tekstin kirjoittaminen, Tampereen teknillinen yli-opisto, 2009, 7 s. Available: http://math.tut.fi/~ruohonen/D-tyo-ohje.pdf
[bookmark: _Ref19529816]E. Salminen, Practical advice for writing publications, course material, TKT-9617 Scientific Publishing, Tampere University of technology, Nov 2009 (updated Apr 2014), 101 p. Available http://www.cs.tut.fi/~ege/Misc/salminen_figures_styles_v15.pdf
[bookmark: _Ref19524876]Guide to Writing a Thesis in Technical Fields: Instructions for Master of Science and Bachelor of Science Theses, Tampere University, Tampere, 2019. Available: POP > Study info > Master's thesis > MSc % thesis guidelines


[bookmark: _Toc535516175]Appendix A: Using text Styles in MS Word
You should minimize the number of text styles in order to keep the document easy to use and modify. Unfortunately, many people use MS Word styles inconsistently or misuse them. In general, the layout should not be tweaked by adding line breaks or other white spaces, but via proper definition of styles. Similarly, numbering figures, tables, and references manually usually leads to problems. One common source of formatting problems is copying text from other documents. It is better to do that as Paste > Paste special > Unformatted text, because otherwise the number of styles explodes. It is tempting to format text by using the buttons on the top ribbon of MS Word, but unfortunately this also leads to trouble. 
By opening Apply Styles and then clicking the icon with two capital A letters, you’ll see the available and actually used text styles in the current document, and you can also modify, delete or add them. By clicking Options… on the bottom-right corner, you can select which to show (all/in use) and which formatting types (paragraph, font, list).
Sometimes text includes rather peculiar styles, such as figures in boldface, italiced 10 pt line breaks, or red line line breaks. Luckily, it is easy to select Select all X instances, from the style menu. Then it is easy to get rid of at least some of the oddballs. For example, the TUT thesis writing guide had over 130 styles in document version 11.3 (see Figure 2a), including the quite similar looking Body text, Body text+Not italic, Normal, Plain text, After:6pt, After:6pt,Line spacing:Single, Before:1pt, Before:1pt,After:0pt, Before:3pt and so on. The style count was reduced to half by replacing those with Normal  and removing the unnecessary ones (Figure 2b).
Moreover, you can Show paragraph marks and other hidden formatting symbols by clicking the filled and mirrored capital P letter looking icon. The pedantic authors can then remove the double white spaces, extra line breaks, extra tabulators and other miscellaneous debris. Check also if copy-pasting from other documents has replaced the quotation marks “…” with "…".
If printing to pdf file degrades image quality, select printer setting High Quality Printing instead of Standard, or select File > Save as Abode PDF.
Formatting options have changed in Wordin 2013, which may cause problems with spacing of headings unless you use Compatibility mode, see for example https://answers.microsoft.com/en-us/office/forum/office_2013_release-word/where-can-i-find-suppress-extra-line-spacing-at/70bf7ca3-a884-40c4-ab59-34d2a04a1a8f
		[image: ]

	a) Version 11.3. Pay attention to numerous Arial based styles, numbered and other lists, and left aligned styles..

	[image: ]

	b) Version 11.5 is better, but still there are Headings 4-9, which are useless but hard to get rid of.


[bookmark: _Toc535515836][bookmark: _Ref19530345][bookmark: _Ref19530392]Styles in writing guide document versions 11.3 and 11.5
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